소프트웨어 요구사항 | DevSecOps 구축 컨설팅, 교육, 기술지원 서비스 제공

소프트웨어 요구사항

GitLab을 설치하고 안정적으로 운영하기 위해 권장하는 소프트웨어 요구사항을 충족해야 합니다.

Ruby 버전#

GitLab에는 Ruby (MRI) 2.6이 필요합니다. GitLab 12.2부터 Ruby 2.5 이하를 더 이상 지원하지 않습니다.

Ruby의 표준 MRI 구현을 사용해야 합니다. 우리는 JRubyRubinius를 좋아하지만 GitLab에는 네이티브 익스텐션(Native Extension)을 가진 여러 Gem이 필요합니다.

Go 버전#

필요한 최소 Go 버전은 1.13입니다.

Git 버전#

GitLab 13.1에서 :

Node.js 버전#

GitLab 12.9부터 Node.js 10.13.0 이상만 지원하고 Node.js 8에 대한 지원을 중단했습니다. (GitLab 11.8에서 Node.js 6 지원이 중단됨)

더 빠르므로 Node 12.x를 권장합니다.

GitLab은 Webpack을 사용하여 프런트엔드 에셋(Assets)을 컴파일하며, 여기에는 최소 Node.js 10.13.0 버전이 필요합니다.

node -v로 실행 중인 버전을 확인할 수 있습니다. v10.13.0 이전 버전을 실행 중인 경우, 최신 버전으로 업데이트해야 합니다. Node.js 웹사이트에서 커뮤니티 유지관리 패키지에서 설치하거나 소스에서 컴파일하는 방법을 찾을 수 있습니다.

Redis 버전#

GitLab 13.0 이상에는 Redis 버전 4.0 이상이 필요합니다.

Redis 버전 5.0 이상이 권장됩니다. 이는 GitLab 12.7부터 시작하는 Omnibus GitLab 패키지와 함께 제공되기 때문입니다.

깃랩 문서 바로가기